2004 F150 FX4 5.4 V8 running rough please help - Ford F150 Forums - Ford F-Series Truck Community.


2004 - 2008 Ford F150 General discussion on the 2004 - 2008 Ford F150 truck.

Reply
 
 
 
Thread Tools Search this Thread
Old 09-21-2014   #1
Junior Member
Thread Starter
 
Join Date: Sep 2014
Posts: 1
Default 2004 F150 FX4 5.4 V8 running rough please help

Hey guys ok to start off this truck was parked for awhile and my wife decided to drive two hours south to see her mother and on her way home the truck started loosing power and check engine light codes came on. I took off the TB and cleaned it but unfortun. I broke to torx 20 screws off in the TB when taking off the TB Sensor so I just ordered a whole new throttle body off ebay which was used and installed it didn't fix the problem still runs rough and has no power. In the meantime the truck sat for awhile and I went out to start it and it was dead so I tried to jump it but the anti theft light was flickering non stop truck wouldn't even turn over so I unhooked the negative off the battery and used a jumper wire to the negative and positive for about 10 mins which fixed the theft issue and truck started fine it will start at about 1000 rpm and the drop to around 500 and up and down continually between 500 and 750 rpm. I hooked up to scanner and got several codes P2104 & P2106 which are throttle actuator control system forced idle, code for O2 sensors on bank 1&2 sensors 1, P0020 & P0010 which are intake camshaft position actuator circuit open on bank 1 & 2 and last P0102 which is Mass or volume air flow A circuit. I am really confused to where to start if I should change the MAF Sensor or the VCT Solenoid, Throttle body sensor or if I just need to have the PCM flashed since a new throttle body was installed. I did install new two o2 sensors in bank 1&2 sensors 1 on both sides so that has been taken care of. Also the previous owner of the truck installed a K&N air filter and he removed the factory air box and air filter to install the new one which I don't think would be an issue since the truck has ran fine for almost a year after I bought it. Any advice on where to start would be greatly appreciated. Thanks
ryanwsmith03 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Troubled 2000 f150 (rough running, missing, etc) Gsragtop 1997 - 2003 Ford F150 0 07-26-2015 01:36 PM
rough running bigtoe1111 1997 - 2003 Ford F150 1 07-07-2014 10:15 PM
35"s on 3.73 gears? 2004 FX4 woogyboogy 2004 - 2008 Ford F150 3 05-01-2013 09:01 AM
rough running 5.4 racewerx Engine Talk & Maintenance 3 05-28-2012 09:25 PM
96 F150 5.8 High Idle... and I've replaced everything! Please help! DEET 1987 - 1996 Ford F150 48 12-04-2011 12:37 AM


Tags
maf, o2 sensors, throttle position sensor, vct solenoid


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 03:21 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.