Hubs or vacuum, please help! - Ford F150 Forums - Ford F-Series Truck Community.

Drivetrain Tech Talk about transmissions, axles, and gears.

Hubs or vacuum, please help!

Old 12-01-2013
  #1  
Junior Member
Thread Starter
 
Join Date: Dec 2013
Posts: 1
Default Hubs or vacuum, please help!

I have a 2005 f150 with just under 100, 000 miles and been having a problem with the front the four wheel drive. Its make a grinding sound when I give it gas going down the road. I brought it home and checked the iwe solenoid for vacuum and no problem but the driverside idoesnt seem like its getting enough vacuum. At this point I lift the front end up and both hubs are spining in 2wd with the truck off, with the truck running in 2wd the hub spins on the passenger side but not the driverside, and in 4wd the hub still spins on the passenger side but not on the driverside. I was hoping that someone can help me out with this because I want to avoid taking it to the dealership with only a third party warranty that will not cover most of it.

Last edited by jselonke; 12-01-2013 at 11:44 AM.
jselonke is offline  
Old 12-27-2013
  #2  
Junior Member
 
Join Date: Dec 2013
Posts: 2
Default Same issues here sounds like.

Hello Jeremiah,
I had the same issue last year, grind/rattling noise in front end, especially accelerating in 2 wheel drive. When I put it in 4x4 it went away. Ended up taking it to a shop and they change a vacuum pump and had no problem until this last month again. So I am trying to locate all my components and check them out. My front axles do not spin in 2 wheel drive with truck running and front jacked up, but do if I turn engine off. I pulled vacuum solenoid (mine is on driver side near brake booster) hose off solenoid while running in 2H and it didn't seem to have any suction, switched to 4H and it pulls good vacuum. I thought in 2W drive it was suppose to have about 4-6 inches of vacuum. Anyone have any ideas where to go next or how this actually is suppose to work? So I am not sure my vacuum solenoid is good or not. Still researching my system.

Last edited by rubis713; 12-27-2013 at 04:32 PM. Reason: correcting
rubis713 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
DEET
1987 - 1996 Ford F150
50
11-26-2018 10:49 PM
beaver22
1997 - 2003 Ford F150
4
01-16-2018 12:17 PM
86ford
Suspension Tech
4
01-13-2015 10:37 PM
hardwick87
1997 - 2003 Ford F150
0
03-15-2014 11:22 PM
henduford
2004 - 2008 Ford F150
0
03-11-2014 02:49 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Hubs or vacuum, please help!


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.